Skip to content

Yamaha RX5 Repair

The Yamaha RX5 is one of my favourite drum machines and when I acquired an example that wasn't 100% working, it seemed like my next rainy Sunday afternoon would be occupied with a Yamaha RX5 repair (or two).

Every once in a while, I receive a mysterious parcel, sometimes from as far away as Japan. It took me a while but I eventually sussed out that my ex-frontman / singer, Rob would occasionally get the urge to buy me something. Anyway, a couple of years ago, one of those parcels contained a Yamaha RX5 drum machine (yes, you read correctly) that indeed had come all the way from Japan.

Being a die-hard Sisters of Mercy fan and like many, wanting to get those big Doctor Avalanche drum sounds, it was quite obvious where Rob was coming from. He'd given the game away, LOL! 😀

While much appreciated, the RX5 wasn’t in great cosmetic condition and outputs 10, 11 and 12 were dead. This wasn't a pad problem as I was getting MIDI. It was defiantly an analogue signal path problem. The machine had been opened before and on close inspection, the membrane cable that connects the main-board to the output board for example, didn't look in great shape.

Despite the issues however, this RX5 came in really useful for testing my Nebula balanced outputs jack-board for the Roland MKS-70. I made a special lead that connected four outputs from the RX5 to the audio inputs on Nebula, where the outputs from the MKS-70’s voice-boards would go. It worked like a charm but to be honest, I would have preferred to have a Yamaha RX5 in my keyboard room.

So, as you do, every once in a while, I’d check out the Yamaha RX5 action at the usual on-line places. Well, a few weeks ago, a RX5 popped up. Cosmetically in great condition it did have a fault and so the auction started at 50 GBP. To cut a long story short, I ended snapping it up for 108 GBP. On top of that, collection was only twenty-five minutes away from where I live. GEEEERATE!!!!!!

Yamaha RX5 on ebay
My patience paid off and I finally found a nice condition Yamaha RX5 for a very reasonable price.

When I went to pick up the unit, the seller showed me the fault and indeed as described, it simply wouldn’t boot properly, with garbled characters cycling randomly on the display and LEDs also randomly coming on and going off. It wasn't even possible to reinitialise the machine so something was clearly very wrong.

Having sussed out that the fault on the RX5 that Rob bought me, was down to a couple of faulty op-amps on the jack-board and that the fault on the unit I’d just bought was on the main CPU-board, I did the obvious thing and just swapped out the main-board in my machine with the one I’d just bought. Okay, so now I have one pretty good condition, working Yamaha RX5. That can now go upstairs into the studio. Yippee!

I put the main-board from the unit I’d just bought into the case of my old unit. Of course, it still didn’t boot properly.

Before switching on loads of test gear, I always do a quick visual inspection. If the item in question will switch on, then I switch it on. On this occasion something was definitely not right as I noticed that an analogue-to-digital converter was getting rather warm. In fact, after half-an-hour or so, it was about 50°C while adjacent devices were only a little over ambient temperature.

A quick check of the power supply revealed that everything was good.

On a side-note, the RX5 power supply puts out +5V derived from a 7809 positive voltage regulator and -4V via a 7905 negative voltage regulator. The configuration is rather clever and unusually allows the heatsink on the 7905 to be connected to 0V.

So, normally associated with the DX range, the Mitsubishi M58990P 28-pin ADC can be found in many early Yamaha digital instruments from that period. Now-a-days it’s not too easy to source but I managed to find one that was unused and for a decent price.

Faulty components removed from Yamaha RX5 repair
The Yamaha RX5 main-board. To the right are the components that I removed; a M58990P and two M5218L dual op-amps.

Unfortunately, IC 12 (the M58990P) wasn't what was causing the malfunction. This ADC is simply for the data and tempo sliders. While it had to be replaced anyway (because it was cooking), I knew it wouldn't fix the problem as it doesn't have anything to do with the computer side of things. This RX5 still wasn't booting. Damn!

I had to dig a little deeper. Code just wasn't running on the processor and data line D3 was definitely duff. Checking connections and realising that the seller I bought this from had swapped out the 63XX series processor, I then discovered two broken tracks. Technically, there were actually three as there was also a break under two linked pins on one of the ICs. After fixing them, I still had a non booting RX5. 🙁

Yamaha RX5 track repair
The guy I bought this off, tried to fix it by changing the HD63B09EP processor. While doing so, he managed to break a couple of tracks.

The signal of the FIRQ into the processor seemed to be playing up, looking like it was only running at about half the speed of what it should be and it kind of looked modulated. A lot of back-tracking and things were becoming quite challenging. I thought that the counter clue in conjunction with the symptoms, would point me in the right direction but intermittently, things like not all 'Chip Enable' lines for the three SRAM devices would come up. In fact, things reached a point which made me concerned that perhaps the firmware had become corrupted or perhaps the voice ROMs had been damaged. Even the SRAM wouldn't be straight-forward to change as there are three TC5564PL-20 devices.

Indeed I ended up changing a lot of logic and even burned a pair of new firmware ROMs.

Interestingly, this RX5, actually had three seemingly unrelated problems; the ADC, two (or three) broken tracks and some duff logic. Hmm... The guy I bought it off, threw in a GliGli RX5 USB card and I'm wondering if that screwed things up somehow. In his attempts to repair it, I'm sorry to say but it looked like he made the situation worse. Those tracks for example, didn't break by themselves.

All in all, my Yamaha RX5 repair took me a couple of days. While I was at it, I also changed the battery and replaced the cheep processor socket with a proper turned pin type. After putting everything back together, reinitialising the unit and restoring factory data, I switched it on and YES, life and.... SOUND!

Mitsubishi M5218LYes, of course ICs fail. That's a big reason why I do what I do! While accepting the ADC going down and even a couple of logic gates, I have to admit to being quite surprised at the failure of the two M5218Ls. Remember that these were technically out of my first RX5. These humble single-in-line dual op-amps are used extensively in equipment manufactured during this period and are amazingly reliable, with a pretty good specification for the time. In fact, I can't remember the last time I had to change one of these, let alone two in the same machine.

Being ex-Roland, you wouldn't be blamed for thinking that I should almost have a natural affinity towards machines like the TR range and even the R-8 but I have to confess that the solid, punchy feel of the Yamaha RX5, was more my cup of tea than the rather traditional, rounded, perhaps even 'jazzy' sounds associated with Roland, at the time.

Yes, I know the RX5 is only 12-bit at 25kHz but just put the specs away for a moment and LISTEN! 😀